Ignorer la navigation

Découverte et/ou révisions

Les définitions

Algorithme : c’est un ensemble de règles opératoires rigoureuses, ordonnant à un processeur d’exécuter dans un ordre déterminé un nombre fini d’opérations élémentaires ; il oblige à une programmation structurée.
Algorigramme : c’est une représentation graphique de l’algorithme. Pour le construire, on utilise des symboles normalisés. Ci-dessous, quelques exemples.

 

Structure LINEAIRE ou SEQUENTIELLE

Exemple:

Algo pour la fonction "ouvrir une salle de classe"

DEBUT
- FAIRE "sortir ses clefs"
- FAIRE "ouvrir la porte"
- FIN

Cela donne sous la forme graphique (algorigramme):

Exercice N°1:

Voici un algorithme de la fonction "élever un chiffre au carré"

Q1: Ecrire l'algorigramme de cet algorithme.

 

 

Structure " ALTERNATIVE REDUITE"

Exemple:

Sur une chaîne de conditionnement un dispositif de tri permet de diriger les caisses de Masse
supérieure ou égale à 20 Kg vers le tapis 1, les autres continuent d’avancer sur le même tapis 2.

 

Exercice N°2:

Soit l'algorithme suivant:

Algorithme SimpleOuDouble : Cet algorithme saisit une valeur entière et affiche son double si cette donnée est inférieure à un seuil donné.

constante (SEUIL : entier) ←10
Variable val : entier

début
     Afficher("Donnez-moi un entier : ") { saisie de la valeur entière}
     Saisir(val)
     si val < SEUIL { comparaison avec le seuil}
          alors val ← val ×2
     Fin si
     Afficher ("Voici la valeur val :" , val)

Fin

Q2: Ecrire l'algorigramme de cet algorithme.

 

 

 Structure " ALTERNATIVE COMPLETE"

Exemple:

Sur une chaîne de conditionnement un dispositif de tri permet de diriger les caisses de masse supérieure ou égale à 20 Kg vers le tapis 1 et les autres vers le tapis 2 en comptabilisant le nombre de
caisses.

 

 

Exercice N°3:

Soit le programme suivant à faire:

  • "Reçu avec mention Assez Bien " si une note est supérieure ou
    égale à 12,
  • " Reçu mention Passable" si elle est supérieure à 10 et
    inférieure à 12, et
  • "Insuffisant" dans tous les autres cas.

cela donne l'algorithme suivant:

si note ≥12
   alors afficher( "Reçu avec mention AB" )
   sinon si note ≥10
             alors afficher( « Reçu mention Passable" )
             sinon afficher("Insuffisant" )
            fin si
fin si

Q3: Ecrire l'algorigramme de cet algorithme.

 

Structure " REPETER... JUSQU'A..."

 

Structure " REPETER... TANT QUE..."

 

Exercice N°4:

l'algorithme réalise la fonction "Fait le total":
Cet algorithme fait la somme des nbVal données que l'utilisateur saisit
constante
début
    totalValeurs←0

    Répéter

       afficher("Donnez une valeur,", STOP, " pour finir.") {amorçage}
       saisir(val)

       totalValeurs←totalValeurs+ val {traitement}

    Tant que val ≠STOP
fin

Q4: Ecrire l'algorigramme de cet algorithme.